This is an absolute FIASCO !

Cedric ROUX roux at
Tue Dec 1 12:52:50 CET 1998

Hi FIASCO people,

i was lost in the net, then i saw a little light up on my head...
it was FIASCO ! so i decided to take a look at it (well, in fact, a
friend of mine told me about it, but a little romance sounds nice, eh ?).

So, first, the hello server works.
Then, i tried the linux one. And nothing to do.
I applied the two patches available.

Here is what's going on :
linux boots, everything seems alright, then it loads the deamons, then
the keymap, then the login should be there, but it reboots.
(don't know if it had to be done, but it checked my hd, and during
this process i had a lot of 'wake_idle_if_needed : ipc failed')

That was the first try.
I tried it just after this boot. And i now have this :
It boots, then at a time (don't remember exactly when), it shows that : failed assertion 't->kernel_sp==0 || reinterpret_cast<vm_offset_t>(t->kernel_op) > reinterpret_cast<vm_offset_t>(t)+sizeof(thread_t)+0x20'
then it's over, asking me to reboot or run the debugger.

So my questions are :
- what does it mean ?
- is it a problem in my compiling of l4-linux ? (i disabled serial support)
(if someone could send me his kernel configuration, you run make xconfig and
you save it and you send it to me, of course if it works !)

I have a pentium 200 mmx 64MHz, a hd ide of 4Go with hda2 for linux and
hda3 for swap (70Mo), there is a cd-rom (hdb).
I have no scsi, if it can help.

I have a second machine, so i could have tried the debugger, but some pieces
are missing and i don't have a null-modem, but i'll try to solve that.

Hope this is not an already known bug.

I'll keep on trying, it was late yesterday, had no time to make more than
two tests.

PS : i have the idea to do a distributed memory managment for my studies, do you
think it's possible with fiasco ? and when you run under l4-linux, can you
make process that directly talk to fiasco ?

Thank you,

More information about the l4-hackers mailing list