l4-linux booted !

Cedric ROUX roux at ecoledoc.lip6.fr
Thu Dec 3 13:15:36 CET 1998

Hello FIASCO people,

well, strange things happened.
I used the same grub floppy than the one used for my first experiments
(that both crashed), and it booted !
really strange...

I tried to run X, it didn't work (my screen power off, surely
because of bad values for the horizontal and vertical frequencies,
but i am not sure. I'll keep on trying (especially basic modes, like
standard vga, and so on).

Then, in a next boot, i tried 'reboot' command and i receive a
KDB: unexpected system call
and all is blocked (i am still in single machine mode, the cables
i need to be able to debug with my second machine are not here yet,
and for Michael: no, my machines are not connected anywhere, so remote
debug won't be possible).
In another test, i tried 'shutdown -h 0', which worked.
Didn't try 'reboot' again, will do it this afternoon.

Then, another time, the boot process blocks with this time the message :
ipc.cc:169 : failed assertion `! in_sender_list()'

Another strange thing is that it too often check the hd, with a message i never
had before :
/dev/hda2 has gone too long without being checked, check forced.
Really really strange.

Now, little questions :
with the rmgr configfile (that i finnaly understood, at first the "glinux"
task was not used because rmgr matched it against the configfile, so i
had to add a line "task", for it to match the good module),
there is a field 'irq'. Isn't it possible to allow only l4-linux
to use the mouse-irq, so we can have mouse ?

For my future work, i absoulty need X to work and the mouse would be
appreciated (but i can deal without it). Once again, by configuring
things correctly in the rmgr configfile, wouldn't it be possible to
run X ? seems that people (especially Michael) succeded in running X, how
did you do !?


PS : this is a repost, the first message doesn't seem to have arrived,
does it ? (i'm sure all those lost mails are preparing something ugly...).
Is your mail server running under fiasco ? :)
Hope this one will come to destination...

sanx to Michael for his kernel config.

More information about the l4-hackers mailing list