OSKit-Problems with newer glibc

Ian Duggan ian at ianduggan.net
Thu Jan 17 11:00:32 CET 2002


> Are there any reported solutions for compiling the oskit1.0 that comes with
> l4 with installed glibc 2.2.4 or newer?
> 
> On my machine (Debian "sid", gcc 2.95.4) it throw a linker error while
> linking unix/linux/sbrk-hack.o together with libc.a because duplicate symbol
> __libc_multiple_libcs. The sbrk-hack's only purpose seems to be defining
> these global variable (as an int). Maybe this was an error in libc and got
> fixed in 2.2.4?
> 
> However when I compiled under glibc 2.1.3-10 (and gcc 2.95.2) it works...

I found I was able to get things to work correctly if I compiled the
Oskit part of the source individually, before running the global
Makefile. Since that worked, I didn't delve into the mechanics of why.

-- Ian

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Ian Duggan                    ian at ianduggan.net
                              http://www.ianduggan.net



More information about the l4-hackers mailing list