compiling L4Env with oskit for Fiasco and L4Linux

Frank Mehnert fm3 at os.inf.tu-dresden.de
Tue May 6 09:39:02 CEST 2003


Hi Etienne,

On Tuesday 06 May 2003 01:36, Etienne Robillard wrote:
> My name is Etienne Robillard and I am studying Art in
> college. I don't have yet any degree in computers
> science, whatsoever.
>
> What I am attempting to do is to build/boot L4Linux
> (and on another time The Hurd, while I'm at it...) on
> a typical x86 machine, Pentium III with 384mb of
> sdram.
>
> oskit = oskit60 (the old version modified for l4 with
> patches)
> gcc = crossgcc 2.95.2 (no libgcc2.a) with pthread-elf
> support, i386/linux emulation
> os = freebsd4.7-p8 (with libc_r/)
> make = gmake
> target = i586-l4-linux (just for fun...)
> build= i386-unknown-freebsd4.7
> binutils = version 2.13.2.1

[compiler output deleted]

> In order to get there, I had to undefined HAVE_CODE16
> in $(OSKIT)/flux/config.h. Otherwise, I would have
> this bug :

You should REALLY use OSKit 0.6 from our public CVS repository.
All these bugs you mentioned are fixed there!

BTW: OSkit is not needed anymore to compile Fiasco.

Frank
-- 
## Dept. of Computer Science, Dresden University of Technology, Germany ##
## E-Mail: fm3 at os.inf.tu-dresden.de    http://os.inf.tu-dresden.de/~fm3 ##
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: signature
URL: <http://os.inf.tu-dresden.de/pipermail/l4-hackers/attachments/20030506/2fee9d01/attachment.sig>


More information about the l4-hackers mailing list