Make error in sys_ipc_wrapper

daviddenny at daviddenny at
Wed Jul 30 22:54:19 CEST 2003

Udo, Thanks.. I tried make clean followed by make... this stopped in the 
same place

NB I'm using the CVS version, downloaded on Saturday or Sunday last, I'm 
not sure.

Bearing in mind my previous problem with tempfile, I am wondering if there 
is a linux distro issue involved. I'm using SuSE8.0 which has a kernel 
level of 2.4.18.

When looking at UML (IIRC), I remember seeing somewhere that the SuSE 
kernel is a bit customised. Maybe this is the problem and there are 
sources missing in my distro that Fiasco/L4 expects.

Do I gather that tu-dresden relies on debian? Maybe I should consider 
installing a debian linux instead, on this machine.

David D

"Udo A. Steinberg" <us15 at>
Sent by: l4-hackers-bounces at
15:05 ZE2 Today

        To:     David Denny <david at>
        cc:     "l4-hackers at" <l4-hackers at>
        Subject:        Re: Make error in sys_ipc_wrapper

On Wed, 30 Jul 2003 06:30:38 +0100 David Denny (DD) wrote:

DD> I attach glpbalconfig.out & last piece of compile log & look forward 
to finding out what I have overlooked


I've tried your configuration and I can build it just fine here. I'm using
the current CVS version. What version are you using? CVS or the Fiasco-1.0
release + patches from our website?

Also, have you tried a "make cleanall" and then a "make"?


Gleichgültigkeit ist die mildeste Form der Toleranz. [Karl Jaspers]
l4-hackers mailing list
l4-hackers at

-------------- next part --------------
A non-text attachment was scrubbed...
Name: att7l6yb.dat
Type: application/octet-stream
Size: 196 bytes
Desc: not available
URL: <>

More information about the l4-hackers mailing list