Double Page Fault problem

Frank Mehnert fm3 at os.inf.tu-dresden.de
Wed Sep 8 18:16:09 CEST 2004


On Wednesday 08 September 2004 18:02, Leon wrote:
> I've noticed that I often get a Double PF error if I load the same (or a
> different program) directly after each other. I've been trying different
> programs to see if I can get a pattern but without any luck. In this debug
> output I ran the program "simple_ts_test" directly after each other and
> .....Double PF error. This has happened to dm_phys_test, thread_test, and
> others.

Very strange. We've fixed an L4env bug today which could be related to your
problem. Please wait until tomorrow until the remote-CVS is in sync and
try again. At least I can not reproduce your bug with dm_phys_test with
our current CVS.

> Q1: Is this just my setup or a possible bug?
>
> I've also noticed that the apps starting directly after each other gets
> the same task-ID. This is new (my 04-08-01 CVS build always incremented
> the number). Maybe this is related to the error?

No, there is no relation.

> Q2: From the debug output - why does it not find library "libloader.s.so"?

It's not a bug, only a message. The loader differs between binaries that
are linked against the libloader.s.so and binaries that are not.

Frank
-- 
## Dept. of Computer Science, Dresden University of Technology, Germany ##
## http://os.inf.tu-dresden.de/~fm3                                     ##
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
URL: <http://os.inf.tu-dresden.de/pipermail/l4-hackers/attachments/20040908/ab589073/attachment.sig>


More information about the l4-hackers mailing list