proxygon problem

Adam Lackorzynski adam at os.inf.tu-dresden.de
Tue Dec 21 11:33:14 CET 2004


On Tue Dec 21, 2004 at 00:57:42 -0800, sbrobson at fastmail.fm wrote:
> Using proxygon i'm able to load applications like hello and vscrtest,
> but as soon as I try to load l4linux I get the following error on the
> serial port:
> 
> hello: My thread-id is 12.0
> hello: My thread-id is 14.0
> proxygon| called con_vc_direct_update_component - not yet implemented.
> proxygon| called con_vc_direct_update_component - not yet implemented.
> proxygon| called con_vc_direct_update_component - not yet implemented.
> proxygon| called con_vc_direct_update_component - not yet implemented.
> proxygon| called con_vc_direct_update_component - not yet implemented.
> hello: My thread-id is 12.0
> hello: My thread-id is 14.0
> proxygon| called con_vc_direct_update_component - not yet implemented.
> proxygon| called con_vc_direct_update_component - not yet implemented.
> proxygon| called con_vc_direct_update_component - not yet implemented.
> proxygon| called con_vc_direct_update_component - not yet implemented.
> proxygon| called con_vc_direct_update_component - not yet implemented.
> 
> l4linux would load when I was still using doperun. I'v been attempting
> to load l4linux using a file with the following:
> 
> verbose 2
> modpath "(nd)/fiasco"
> task "run"
> task "vmlinuz.l4env" "root=/dev/hda3 ro l4irqack=linux"
> 
> Any suggestions?

Proxygon does not implement the full con interface, as you can see. One
has to make sure to first query for dope and if that fails, try con.
Looks like I haven't fixed that in 2.4...




Adam
-- 
Adam                 adam at os.inf.tu-dresden.de
  Lackorzynski         http://os.inf.tu-dresden.de/~adam/




More information about the l4-hackers mailing list