Jayesh Salvi jayesh.salvi at
Wed Feb 2 17:31:33 CET 2005



I downloaded the cvs module grub from .


I built the binaries. Doing make, make check, make install did not
install this GRUB version (0.90..), my old gnu version (0.93) is what
gets loaded when I restart the machine. I also ran the grub-install file
from build/util directory:


./grub-install /dev/hda6

Installation finished. No error reported.

This is the contents of the device map /boot/grub/

Check if this is correct or not. If any of the lines is incorrect,

fix it and re-run the script `grub-install'.


# this device map was generated by anaconda

(fd0)     /dev/fd0

(hd0)     /dev/hda


/dev/hda6 is where my " / " mounted.


After this also my old grub is being loaded. I then manually changed the
files in /boot/grub, /sbin/grub, /usr/bin/mbchk, but still no luck.


I need this GRUB version to boot the L4Linux-fiasco from my hard-drive. 


What do I have to do to get my laptop (Pentium M) load this new GRUB?







-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the l4-hackers mailing list