compilation error for l4linux 2.6

Adam Lackorzynski adam at
Sat Feb 12 19:48:38 CET 2005

On Sat Feb 12, 2005 at 11:30:57 -0600, Jayesh Salvi wrote:
> That sounds promising Adam. But I am having this trouble with compiling
> L4Env. I downloaded all the stuff, and tried to compile the L4Env. But
> L4Env needs linux22 (I have no clue why?) I have that in ../l4linux22

Some things are built for linux22 but the build system should just skip
them if gcc-2.95 is not available.

> directory, but inside a makefile in l4linux22/arch/l4/ there is a hard
> coded requirement for GCC to be 2.95 and my compilation stops at that
> point. I have GCC 3.3 something. 

Linux-2.2 does not support gcc-3.x so that this hardcoding is needed.

> Can someone tell me what should be done in this case?

First, delete linux22, you do not need it. In any case you should be
able to remove those parts that will not build. But better show the build
log so that I can fix them up or help better.

Adam                 adam at

More information about the l4-hackers mailing list