deprecated practices in grub package - cause problem with gcc 3.4.2

Tiago João Portela Jorge tjpj at
Thu Feb 24 10:47:07 CET 2005

>I recently installed Fedora Core 3 and tried to compile the grub package
>for L4 using gcc 3.4.2

don't use gcc 3.x to compile Grub. It has many things that aren't supported in
earlier versions like strings in printfs scattered through several lines. My
advice to you is use gcc 2.95. Also check if you have ncurses installed in your
system. Use synaptic ;). It's easier.

Tiago Jorge

More information about the l4-hackers mailing list