wrong gcc major version "2"- use 3.x for l4io

Christian Helmuth ch12 at os.inf.tu-dresden.de
Wed Dec 21 12:21:26 CET 2005


On Tue, Dec 20, 2005 at 07:25:31PM +0000, Konstantinos Pachopoulos wrote:
> Hi,
> issuing a "make" in /usr/src/l4linux/l4, i end up with
> this error:
> -----------------------------------------------------
> ===Building IDL & includes of "l4io"===
> PWD= /usr/src/l4linux/l4/pkg/l4io make -C l4io idl
> make[2]: Entering directory
> '/usr/src/l4linux/l4/pkg/l4io'
> Makefile:8: ***Wrong gcc major version "2"- use 3.x
> for l4io. Stop.
> make[2]: Leaving directory
> '/usr/src/l4linux/l4/pkg/l4io'
> make[1]: ***[l4io.headers] Error 2
> make[1]: Leaving directory '/usr/src/l4linux/l4/pkg'
> make: ***[pkg] Error 2
> kastor:/usr/src/l4linux/l4#
> -----------------------------------------------------
> I use gcc-2.95 for this. However, using gcc-3.3, i
> ended up with exactly the same error.
> Any ideas about the l4io problem?

IMO "make config" in the l4 directory, setting "Compilers and Tools ->
CC_x86 / CXX_x86", and rebuilding should solve your problem. If not try
"make VERBOSE=" in l4/pkg/l4io and check if gcc-3.3 is used. Maybe you
have a Makeconf.local file around?

I hope this helps
Christian Helmuth

TU Dresden, Dept. of CS
Operating Systems Group

More information about the l4-hackers mailing list