Problems with the demo CD and qemu

Cedric Roux Cedric.Roux at
Fri Feb 18 11:24:07 CET 2005

On Mon, 14 Feb 2005, Adam Lackorzynski wrote:

> On Mon Feb 14, 2005 at 10:40:17 +0100, Cedric Roux wrote:
> I know, but haven't found time yet to look deeper into it. Something
> broke, that's sure. Disabling TLS could help for the time being (rm -r
> /lib/tls...).

L4Linux is there, thanks.

The protection fault was occuring when fiasco calls switch_cpu,
there is a "pop gs" that generates the protection fault.
That's all I can to help you. The TLS stuff is out of my knowledge,
and I run out of time for this. The system boots without the
TLS handling of the tls/libc (or libpthread), that's fine for me :)
(I just tried a boot without CONFIG_HANDLE_SEGMENTS, it crashed,
I did not try to know why.)

It would be nice to have some infos about this issue, though,
just to understand what's exactly going on. Do you, Adam, or
someone else, have pointers or info about it? A second question
is: is the CONFIG_HANDLE_SEGMENTS mandatory and why? More generally,
what option in the fiasco configuration are mandatory and what
are optionnal, and what's the best configuration (having speed
constraints in mind)?


> Adam

More information about the l4-hackers mailing list