OSKit socket example compilation problem

Adam Lackorzynski adam at os.inf.tu-dresden.de
Wed Feb 23 14:35:11 CET 2005

On Tue Feb 22, 2005 at 21:12:08 +0000, Tiago Jorge wrote:
> -I/home/tiago/drops/include/c++/2.95/drops 
> -I/usr/lib/gcc-lib/i386-linux/2.95.4/include -gstabs+     -g -O2 
> -fno-strict-aliasing -march=i586 -Wall -Wstrict-prototypes 
> -Wmissing-prototypes -Wmissing-declarations  
> /home/tiago/l4/pkg/testecom/server/src/main.c -o main.o
> In file included from ../../../../../../oskit10/oskit/c/netinet/in.h:46,
>                 from ../../../../../../oskit10/oskit/net/bootp.h:24,
>                 from /home/tiago/l4/pkg/testecom/server/src/bootp.h:30,
>                 from /home/tiago/l4/pkg/testecom/server/src/main.c:49:
> ../../../../../../oskit10/oskit/machine/endian.h:82: warning: 
> `__word_swap_long' redefined
> /home/tiago/drops/include/oskit10/oskit/freebsd/machine/endian.h:74: 
> warning: this is the location of the previous definition
> ../../../../../../oskit10/oskit/machine/endian.h:99: warning: 
> `__byte_swap_long' redefined
> /home/tiago/drops/include/oskit10/oskit/freebsd/machine/endian.h:91: 

> *The BID is including doubled headers. I've tried to create a costum 
> mode in modes.inc and removing some include dirs but it didn't worked as 
> well, so i have came back to l4env_freebsd. How can i solve this problem?

Well, BID is not including any headers, it's just setting include paths.
Are you including any of the freebsd headers in your program first? I
guess freebsd and oskit headers do not mix too well, at least in this
area. But I'm far from giving any real hint as I'm unfamiliar with this.
I hope you can fix this up yourself.

Adam                 adam at os.inf.tu-dresden.de
  Lackorzynski         http://os.inf.tu-dresden.de/~adam/

More information about the l4-hackers mailing list