Problem loading a module added to drops-rd

Derick Swanepoel dswanepoel at
Mon Mar 14 09:02:07 CET 2005

On Thu, 10 Mar 2005 15:00:59 +0100, Frank Mehnert
<fm3 at> wrote:
> On Thursday 10 March 2005 14:09, Leon Brits wrote:
> > I added a kernel module to the drops-rd ramdisk, but when I 'insmod' it
> > I get the error: Floating point exception.
> >
> > I did enable kernel loadable modules without versions in the L4Linux
> > kernel config. (Using l4linux-2.4.28)
> >
> > Any ideas why - and how to resolve this?
> Which compiler did you use to compile the module? Which options?
> Try -march=i686 -mpcu=<your CPU>. Don't use -march=pentium3 or
> -march=pentium4 since code compiled with this options may contain
> floating point or SSE instructions.

I've been having the same problem and have tried several different
configurations in an attempt to isolate it. The CFLAGS are the
standard ones used when compiling the kernel for Pentium-Classic
(-march=i686). (As an aside, all the Pentium-* options in the kernel
configuration results in the kernel being compiled with -march=i686,
even when Pentium-4 is selected.) The compiler is gcc 3.3.4.

However, I don't think this is a compiler / flags issue because
loading *any* module causes the "Floating point exception" error. I
have tried compiling the kernel with a clean configuration on another
machine with an identical compiler / toolchain, and sometimes it
works, but mostly it doesn't.


More information about the l4-hackers mailing list