L4Linux hangs on self-compiled fiasco

Adam Lackorzynski adam at os.inf.tu-dresden.de
Tue Mar 29 22:48:59 CEST 2005


On Tue Mar 29, 2005 at 14:22:19 +0200, Björn Fischer wrote:
> As a starting point I had the demo CD from the OS research day 2004.
> At first I used the binaries from the cd (including the config files)
> and ran them on top of vmware. Modules were loaded successfully via
> tftp and worked (well, when accessing the cd, L4Linux had the prob
> that there was no cd anymore, but at least the kernel worked well).
> After that I compiled the cvs tree and replaced the binaries by the
> own-compiled ones. It seems that fiasco and DOpE work fine since it
> renders nice windows and so on. But when it comes to starting L4Linux
> it crashes - well, in fact it just "hangs" and does nothing anymore.
> The weird thing is that the bootmessages, the ones printed in the "\ m
> /" window do not end at a reproducable point. Sometimes it comes up to
> "======> L4Linux 2.6 starting <========", sometimes only up to "loader
> : vmlinuz26,#d: Continue at l4env_init (00014264, libloader.s.so)",
> sometimes it hangs in the middle of a message.

I guess that it jumps into the kernel debugger for some reason. The
graphical output gets as far as the redraws get.

For such situations it is useful to have a serial cable to see the
debugging output over the serial, esp. when the graphics mode is on
(remove the noserial option then).

For debugging you can also leave out the graphical mode so that you stay
in text mode and see the output on the screen. A simpler setup like the
following should suffice for this:

 title simple
 kernel (nd)/drops/rmgr -sigma0 task modname "bmodfs" module module module module
 modaddr 0x02000000
 module (nd)/drops/fiasco -nokdb -nowait -noserial
 module (nd)/drops/sigma0
 module (nd)/drops/names
 module (nd)/drops/log
 module (nd)/drops/dm_phys
 module (nd)/drops/simple_ts -t 380
 module (nd)/drops/rtc
 module (nd)/drops/l4io --noirq
 module (nd)/drops/bmodfs
  module (nd)/drops/libloader.s.so
  module (nd)/drops/vmlinuz26
  module (nd)/drops/cfg/l4linux26.cd.k_us.cfg
  module (nd)/drops/drops-rd.rd
 module (nd)/drops/l4exec
 module (nd)/drops/loader --fprov=BMODFS l4linux26.cd.k_us.cfg

You will not see any Linux user output, depending on your kernel

I changed some things between last December and now, so mixing binaries
from then and now might not work and maybe the cause of the trouble.

Adam                 adam at os.inf.tu-dresden.de
  Lackorzynski         http://os.inf.tu-dresden.de/~adam/

More information about the l4-hackers mailing list