TFTP server and E1000 problem

Adam Lackorzynski adam at
Sat Jun 4 02:37:58 CEST 2005


On Fri Jun 03, 2005 at 14:17:45 +0200, Leon Brits wrote:
> I've just received an Intel E1000(82545GM) NIC to make work with the
> TFTP server. The problem is that it does not seem to receive packets
> when connected to a GigE switch. It does work with a Fast Ethernet
> switch. The switches are from the same manufacturer. I do see the
> initial DHCP/BOOTP message send out, so I added some debug code to the
> rx-polling routine and it does not ever receive anything.
> I've looked on the Etherboot-project's mailing list and found some
> comments to a similar error back in 2002 but no mention of a reason or a
> fix.

I think we onced tried an e1000 and it worked but that probably was
another model.
There are netboot/e1000 patches for GRUB floating around, do you happen
to use such a GRUB and does it work?
Does PXE work with the GE switch?
Maybe there are more recent netboot drivers available that could be
plugged in?

Adam                 adam at

More information about the l4-hackers mailing list