l4linux26 @ fiasco-ux w/ dietlibc

Frank Mehnert fm3 at os.inf.tu-dresden.de
Wed Oct 26 16:30:42 CEST 2005

Hi Marko,

On Tuesday 25 October 2005 14:28, Marko Wolf wrote:
> Unfortunatly, l4linux causes a null pointer exceptions (see attached log).
> I tried various kernel compiler options with always the same error. Any
> idea for the reason or what I can try else?

Please could you provide more information: The program code near the
crashing EIP is important. Please start your script again, and do

  objdump -ld \
    --start-address=<faulting EIP - 0x80> \
    --stop-address=<faulting EIP + 0x80> \
    vmlinux > vmlinux.dump

and send the resulting file vmlinux.dump to his list.


## Dept. of Computer Science, Dresden University of Technology, Germany ##
## http://os.inf.tu-dresden.de/~fm3                                     ##
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
URL: <http://os.inf.tu-dresden.de/pipermail/l4-hackers/attachments/20051026/089f8d24/attachment-0001.sig>

More information about the l4-hackers mailing list