L4Linux without Con or DoPe?

Marcel Selhorst l4hackers at selhorst.net
Sat Nov 5 16:13:09 CET 2005

Hi Frank,

I tried a lot of things now, but I am not able to get L4Linux working with the
VESA-fb and without l4fb through Con/Dope.
If I boot Fiasco and L4Linux without l4fb and using vbeset, I see nothing.
If I boot Fiasco and L4Linux without l4fb and not using vbeset, I see the log below.
(grepped via serial console)
If I compile in the VGA-console, l4linux runs smoothly, but I don't get the VESA-fb
Attaching commandline options to the l4linux-kernel (e.g., vga=791 or video=vesa...)
does actually do nothing.

Any further ideas? Attached you'll find my .config-file.

Thanks in advance and best regards,

Marcel Selhorst

*loader  | vmlinuz26,#d: Starting at l4loader_init (000164d0)
*exec    | vmlinuz26: Linking
*exec    | vmlinuz26: Relocating entry 00400000 => 00400000
*exec    | vmlinuz26: Packed 721705 bytes of symbols
*exec    | vmlinuz26: Packed 2050734 bytes of lines
*loader  | vmlinuz26,#d: Continue at l4env_init (000164e0, libloader.s.so)
*l4lx    | crt0_construction called.
*l4lx    | ======> L4Linux 2.6 starting... <========
*l4lx    | Binary name: vmlinuz26
*l4lx    | Kernel command line (9 args): mem=128M noreplacement root=1:0 load_ra
*l4lx    : mdisk=1 ramdisk_size=56000 l4env_rd=ramdisk.gz panicblink=0 lang=de v
*l4lx    : ga=791
*l4lx    | My DMphys is at 06.00
*l4lx    | My region mapper is at 0d.00
*l4lx    | My code starts at 0x00400000 and ends at 0x00740188 [3328 KiB].
*l4lx    | Semaphore thread ID: 0d.01
*l4lx    | Areas:
*l4lx    | Text:     00400000 - 00649000 [2340kB] (a bit longer)
*l4lx    | Data:     00649000 - 006a3388 [360kB]
*l4lx    | Initdata: 006a6000 - 006d5000 [188kB]
*l4lx    | BSS:      006d5008 - 00740188 [428kB]
*l4lx    | l4lx_thread_create: Created thread 0d.03 (server)
*l4lx    | main thread will be 0d.03
*l4lx    | l4env_register_pointer_section: addr = 00400000 size = 3407872
*l4lx    | with-init: virt: 0x00400000 to 0x0073ffff [3328 KiB]
*l4lx    | Noncontinuous region for with-init
*l4lx    | Probably region overflow for with-init?!
*l4lx    | with-init: Number of physical regions: 6, 3407872 Bytes
*l4lx    | with-init: 1: Phys: 0x01415000 to 0x01497000, Size:   532480
*l4lx    | with-init: 2: Phys: 0x01150000 to 0x01220000, Size:   851968
*l4lx    | with-init: 3: Phys: 0x01355000 to 0x01400000, Size:   700416
*l4lx    | with-init: 4: Phys: 0x01259000 to 0x01300000, Size:   684032
*l4lx    | with-init: 5: Phys: 0x001ca000 to 0x00240000, Size:   483328
*l4lx    | with-init: 6: Phys: 0x010da000 to 0x01100000, Size:   155648
*l4lx    | l4env_linux_startup thread 3.
*l4lx    | main thread: received startup message.
*l4lx    | setup_l4env_memory: Forcing superpages for main memory
*l4lx    | Main memory size: 128MB
*l4lx    | Mainmem DS id: 68
*l4lx    | mainmem: virt: 0x00800000 to 0x087fffff [131072 KiB]
*l4lx    | Main thread running, waiting...
*l4lx    | mainmem: Number of physical regions: 1, 134217728 Bytes
*l4lx    | mainmem: 1: Phys: 0x0a800000 to 0x12800000, Size: 134217728
*l4lx    | Filling lower ptabs...
*l4lx    | Done (1047 entries).
*l4lx    | l4env_rd_path: ramdisk.gz
*l4lx    | Loading: ramdisk.gz
*l4lx    | INITRD: Size of RAMdisk is 55000KiB
*l4lx    | RAMdisk from 08800000 to 0bdb6000 [55000KiB]
*l4lx    | l4lx_thread_create: Created thread 0d.04 (timer.i0)
*l4lx    | l4lx_thread_create: Created thread 0d.05 (IRQ12)
*l4lx    | l4lx_thread_create: Created thread 0d.06 (IRQ15)
*l4lx    | l4lx_thread_create: Created thread 0d.07 (IRQ1)
*l4lx    | l4lx_thread_create: Created thread 0d.08 (IRQ11)

Frank Mehnert schrieb:
> On Friday 28 October 2005 10:45, you wrote:
>>Hi Frank,
>>>Should be possible. Just enable the framebuffer but not l4fb. Where is
>>>the problem?
>>I tried that, but the linux console is just blank and the only output I get
>>is from fiasco...
> Please send me your .config file.
> Frank
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: .config
URL: <http://os.inf.tu-dresden.de/pipermail/l4-hackers/attachments/20051105/f6e1a2f6/attachment-0001.ksh>

More information about the l4-hackers mailing list