L4Linux without Con or DoPe?

Frank Mehnert fm3 at os.inf.tu-dresden.de
Sun Nov 6 23:54:29 CET 2005


you did not mention that you wanna to use the _VESA_ framebuffer :-)

On Saturday 05 November 2005 16:13, Marcel Selhorst wrote:
> I tried a lot of things now, but I am not able to get L4Linux working with
> the VESA-fb and without l4fb through Con/Dope.
> If I boot Fiasco and L4Linux without l4fb and using vbeset, I see nothing.

This is the configuration which _would_ work with some special support from
L4Linux 2.6 (see below).

> If I boot Fiasco and L4Linux without l4fb and not using vbeset, I see the
> log below. (grepped via serial console)

Hint: Start the logserver to save some time when applications searching for
their logserver (note the '*' after the prognames in the log).

> If I compile in the VGA-console, l4linux runs smoothly, but I don't get the
> VESA-fb running...
> Attaching commandline options to the l4linux-kernel (e.g., vga=791 or
> video=vesa...) does actually do nothing.

Linux tries to execute int10 to set the VESA mode but L4 applications are not
allowed to execute real-mode code. For example, the L4 console executes int10
calls via the x86emu real mode emulator ...

> Any further ideas? Attached you'll find my .config-file.

If you really want to use the VESA framebuffer driver together with L4Linux
then you have to make sure that the video mode information provided by GRUB
after vbeset is passed to the VESA driver (struct screen_info). L4Linux-2.2
has support for exactly that logic, see linux22/arch/l4/kernel/setup.c line
333. If have not tried to port this code to L4Linux-2.6, the appropriate
place would probalby be l4linux-2.6/arch/l4/kernel/arch-i386/setup.c function
setup_arch. You should have a look at l4linux-2.6/drivers/video/vesafb.c to
find out what the VESA driver expects (e.g. screen_info.orig_video_isVGA
must be set to VIDEO_TYPE_VLFB, ...).

If you get this configuration running, feel free to post an appropriate

Other framebuffer drivers than VESA which don't use BIOS calls to setup the
video mode should work _without_ vbeset.

## Dept. of Computer Science, Dresden University of Technology, Germany ##
## http://os.inf.tu-dresden.de/~fm3                                     ##
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
URL: <http://os.inf.tu-dresden.de/pipermail/l4-hackers/attachments/20051106/d50a146e/attachment-0001.sig>

More information about the l4-hackers mailing list