gdb remote debugging + shared video ram question

s6994440 at s6994440 at
Mon Jan 30 14:49:19 CET 2006


I'm a l4 beginner. So I have 2 questions to standard issues (guess) .


I followed the Building & Using Fiasco html to the debugging point.
- I removed the -nowait Kerneloption
- I edited the .gdbinit file with
	>  file ../build_x862/kernel.image  (current compiled kernel)
	>  target remote /dev/ttyS0	(debugging on COM1)
- When fiasco comes up, I start gdb and immediatly after that my
testmachine reboots, when it comes back up everytime i type c in my host
debugger it reboots again.
- When I use >  file ../build_x86/kernel.image, a kernelimage I built some
time ago, gdb says > 0x00000000 in ?? ()
and again, when I press c it reboots.
- There was no KDB::Init- Message at all.
- I expected the kernel to continue normal operation like with the
"nowait" option after pressing c in the debugger..., Am I wrong ?
- Kernelconfiguration in globalconfig.out
- My menu.lst:
     38 title fiasco
     39 kernel $(P)/bootstrap
     40 modaddr 0x02000000
     41 module $(PF)/fiasco-o -comport 1 -comspeed 115200
     42 module $(P)/sigma0
     43 module $(P)/roottask


My testmachine is an Advantech PCM 5820. It shares the video mem with
normal RAM. When I boot up DOpE I get several error messages (see file
The following lines put L4io about my video:

io      |   40800000-40ffffff : Cyrix Corporation 5530 Video [Kahlua]
io      | WARNING: Cannot handle memory 40800000-40ffffff for device

So I guess it couldn't get the RAM it wanted to ?

When I tried to boot up with L4Con these messages appeared :

con     | Mapping I/O video mem 40800000 => 00400000+000000 [4096kB]
con     | [8.2] l4con/server/src/con_hw/iomem.c:61:map_io_mem():
con     |  I/O video memory address is below 2GB (0x80000000),
con     | don't know how to map it as device super I/O page.

So I guess my video mem is mapped to 0x00400000 via Hardware ?

DM_Phys has allocated this AREA (0x00400000-0x00800000). So I tried to
reserve this area with its --reserve option. Plus I dissabled L4log for
the moment because it was mapped into the AREA by the roottask. But it
didn't help, maybe already sigma0 has this area, so i cannot be remapped

So I read a little along the source of sigma0, but didn't find anything

Hopefully you can help me ?!

Thanks, Marcus
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: error.txt
URL: <>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: globalconfig.out
Type: application/octet-stream
Size: 1709 bytes
Desc: not available
URL: <>

More information about the l4-hackers mailing list