Make hello stops with an error

Adam Lackorzynski adam at
Wed Apr 5 00:21:03 CEST 2006


On Tue Apr 04, 2006 at 23:40:44 +0200, Ricard de Benito Panillo wrote:
> the following error arises making 'hello':
> cc1: note: obsolete option -I- used, please use -iquote instead
> In file included from ../libkern/x86/base_cpu_init.c:22:
> ../flux/x86/base_trap.h:105: error: array type has incomplete element type
> make[3]: *** [base_cpu_init.o] Error 1
> gcc version 4.0.2 20051125 (Red Hat 4.0.2-8) on Fedora Core 4
> Any hint? it seems that the compiler versions is newer than expected.

Indeed, at least for the oskit mode. Please select dietlibc or uclibc in
the config menu in l4/ and try again. uclibc is the default now, and
oskit will go away in some time.

Adam                 adam at

More information about the l4-hackers mailing list