[EMSCB] L4Linux + IPC

Oskar Senft oskar.senft at crypto.rub.de
Wed May 3 18:20:44 CEST 2006

Hi folks!

> As I previously said, our programs used to run with older DROPS versions
> ... what happened?
So, I made some more tests, all with DROPS / L4Env from yesterday (with
Adams patch for "loader").

Test 1)
- new DROPS
- new FIASCO
- new L4Linux
Causes IPC problems (as already stated).

Test 2)
- new DROPS
- new FIASCO
- old L4Linux (from January)
Linker error:
exec    | vmlinuz26-l4linux-2.6.15-hddenc: Symbol atexit NOT FOUND

Test 3)
- new DROPS
- old FIASCO (from January)
- new L4Linux
This one works!! The problems with IPC disappeared. Anyway, I get a
"warning" saying which has to be accepted in JDB by "Go":
l4lx    | The kernel ABI version is too low: kernel has 4, I need 5

>From that, I would state, that there is either a problem in FIASCO
itself or in our configuration of FIASCO.


More information about the l4-hackers mailing list