Binary Compatibility of compiled programs in different DROPS versions?

Adam Lackorzynski adam at
Sun Jun 25 21:04:29 CEST 2006

On Thu Jun 22, 2006 at 13:31:48 +0200, Arthur Mielimonka wrote:
> can you tell me if programs compiled for a specific DROPS version are
> runable on other DROPS versions as well? Or is it necessary to compile
> the program on each target machine? 
> I do not talk about programs like dm_phys or rmgr but about user
> applications which use some DROPS RT-functions.

Generally this is possible but also depends on changes made on
components that communicate with each other. If the IDL or any other
protocol is changed in an incompatible way it will not work or cause
So we usually recommend to have everything up to date.

Adam                 adam at

More information about the l4-hackers mailing list