Semaphore library error on L4Env/Fiasco-UX

Alexander Boettcher boettcher at
Tue Aug 8 01:23:07 CEST 2006

Hash: SHA1


Andreas Niederl wrote:
> Hi,
> Alexander Boettcher wrote:
>> Hash: SHA1
>> Hi,
>> Andreas Niederl wrote:
>>> Hi,
>>> using the current CVS version of Fiasco and L4Env I get the following
>>> error on startup of the system with Fiasco-UX:
>>> exec    | Startup: semaphore lib initialization failed (-1)!
>>> The task on which it fails varies depending on which startup script
>>> from l4/tool/runux is executed but it's always the first or second
>>> task that starts.
>>> L4Env is compiled with gcc-3.3.6 and Fiasco with gcc-4.0.2.
>>> Is this a known problem?
>> no. At least I cannot reproduce it.
>> Ok, a little bit tracking: The message is from
>> l4env/lib/src/startup.c:320. That means that l4semaphore_init returns
>> - -1. This function is defined in semaphore/lib/src/semaphore.c:494. If
>> the function returns -1, one of the following message should be logged:
>> "Missing 'deceit_bit_disables_switch' kernel feature!"
>> or
>> "L4semaphore: failed to create semaphore thread"
>> Which one is it in your configuration ?
> Neither. Using the con script from l4/tools/runux the modules get loaded
> and right after that I am greeted by:
> con     | Startup: semaphore lib initialization failed (-1)!
only one remark. If neither of the messages appear, then the "Enable
RELEASE flag" is enabled in the L4Env configuration ("Advanced -->").
Disable it in order to get more verbose messages (debugging & errors).

> --PANIC---------------------------------------------ESP:00b23f60
> EIP:00b0d20c
> But I do have the 'deceit_bit_disablese_switch' feature disabled and by
> enabling it it works for my configuration.
> Thank you very much.
No problem.

Alex B.

Version: GnuPG v1.4.1 (GNU/Linux)
Comment: Using GnuPG with Mozilla -


More information about the l4-hackers mailing list