get error when compiling fiasco-1.1 with gcc 4.1.2

Zheng Da zhengda1936 at
Wed Sep 13 17:00:10 CEST 2006

I got fiasco-1.1-oskit.tar.bz2.tar and fiasco-1.1.tar.bz2.tar, and unpacked
them into one directory.
I have build the kernel successfully with gcc 3.x.
But when my gcc updated to 4.1.2, I can't build the kernel at all.
The two tar-balls are unpacked to the directory /storage/soft/l4/tmp/fiasco-
And the error I got is as follow:
make[3]: Entering directory `/storage/soft/l4/tmp/fiasco-1.1/oskit/libkern'
gcc -c -MD -DHAVE_CONFIG_H  -I. -I../libkern/x86 -I../libkern/x86/trap
-I../libkern/x86/pc -I../libkern -iquote -I.. -I.. -I../flux/c -nostdinc -g
-O2 -march=i586 -Wall  ../libkern/x86/base_cpu_init.c
In file included from ../libkern/x86/base_cpu_init.c:22:
../flux/x86/base_trap.h:105: error: array type has incomplete element type
make[3]: *** [base_cpu_init.o] Error 1
make[3]: Leaving directory `/storage/soft/l4/tmp/fiasco-1.1/oskit/libkern'
make[2]: *** [libkern/all.MAKE] Error 2
make[2]: Leaving directory `/storage/soft/l4/tmp/fiasco-1.1/oskit'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/storage/soft/l4/tmp/fiasco-1.1/oskit'
make: *** [../oskit] Error 2
Quite strange.
Does anyone compile fiasco1.1 successfully with gcc 4.x?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the l4-hackers mailing list