L4Linux on Xscale

Wan-Keun Jo jowkju at postech.ac.kr
Sat Sep 30 12:19:42 CEST 2006


I tried to install Fiasco-L4Linux on Xscale-PXA255. 
I saw a "hello message" with fiasco kernel, sigma0, roottask, hello programs yesterday.

When I start to compile L4linux, I got the following errors...

/l4linux-2.6$ make

CHK     include/linux/version.h
CC      arch/l4/kernel/asm-offsets.s
cc1: error: invalid option `abi=apcs-gnu'                                 (1)
cc1: error: bad value (armv4) for -march= switch                      (2)
cc1: error: bad value (armv4) for -mcpu= switch
make[1]: *** [arch/l4/kernel/asm-offsets.s] Error 1
make: *** [prepare0] Error 2

>> Question 01:

Error (1): I solved by fixing the following code

CFLAGS_ABI :=$(call cc-option,-mapcs-32,-mabi=apcs-gnu) $(call cc-option,-mno-thumb-

[change to]

CFLAGS += $(call cc-option,-mapcs-32,$(call cc-option,-mabi=apcs-gnu),) $(call cc-option,

Error (1) is solved, but what is the difference between them?? (I just fix it, I don't know why...)

>> Question 02:
Error (2): I read what "-march" option is on gcc manual, and found the permissible values for it are

armv2, armv2a, armv3, armv3m, armv4, armv4t, armv5, armv5t, armv5te, armv6, armv6j, iwmmxt, ep9312

In the file "arch/l4/Makefile:82 CFLAGS += -D__LINUX_ARM_ARCH__=4 -march=armv4"
I just tried each values one by one for -march option, but all failed.

How can I fix it and compile well???

Thank you!!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://os.inf.tu-dresden.de/pipermail/l4-hackers/attachments/20060930/ddb54e49/attachment.html>

More information about the l4-hackers mailing list