Open /dev/console problem with the new l4linux-2.6.18 on Xscale

WanKeun Jo jowkju at
Wed Oct 18 04:00:08 CEST 2006


I first had tried to install l4linux-2.6.17 with fiasco kernel on Xscale. 
I got error which I already posted before on boot process. That was due to bugs in fiasco kernel,
by Adam Lackorzynski's advice. so I updated Fiasco kernel & l4linux-2.6.18 from CVS.

Again, I tried to boot, but failed with the following warning message:

"Warning: Unable to open an initial console"

After loading ramdisk on boot process, the system fail to look up the /dev/console file in ramdisk.
So like before, I added devfs options to fs/Kconfig for mounting devfs filesystem again and then
tried to boot, but failed....

You said before "enabling devfs option" is no option as it's gone with 2.6.18. 
"devfs" is completely obsoleted by "udev"?? 

Then How can I use devfs filesystem and succeed to open the initial console file and boot??

Thank you so much...
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the l4-hackers mailing list