Reloading L4Linux problem

Jugwan Eom zugwan at
Mon Mar 13 08:18:14 CET 2006

2006-03-12 (일), 19:19 +0100, Martin Pohlack 쓰시길:
> Hi Jugwan,
> > I encountered problems reloading L4Linux. After shutdown loaded L4Linux,
> > I tried reloading the L4Linux (same configuration) using 'l' command in
> > l4con but it didn't work(network device probe failed, lost ide disk
> > interrupt). During booting L4linux showed "irq_thread: RMGR denied IRQ
> > 14: code 0x1".
> > Because I use l4con, I can see the system memory on bottom right. After
> > shutdown loaded L4Linux, it still shows the same value before. Using 'a'
> > command in l4con memory region used by previous L4Linux seem to be still
> > allocated. IMHO, this is the source to fail to reloading L4Linux.
> > Because memory region by used L4Linux includes the DMA region, reloading
> > L4Linux cannot control the system device.
> > Is this a bug in L4Linux or other L4Env server? Also, see the attached
> > log.
> IIRC, for restarting and resource freeing to work your need to start the
> event server and tell all participating parties to use it (most often
> the --events switch).
> Maybe others can provide more detail on this .

Thanks martin for advice. I tried to reload L4Linux with event server
but still failed though some incorrect behavior disappeared. After
shutdown loaded L4Linux, l4con showed the memory used by L4Linux was
returned. But using 'a' command in run (not l4con, it's my mistake in
previous mail) memory region is still allocated to the L4Linux. And
reloading L4Linux still failed. Booting reloaded L4Linux hung in
acquiring IRQ 11 (network card) and CPU utilization became 100%.

And I couldn't find using levent library or event related functions
(levents_*) in either L4Linux Makefile (l4linux-2.6/arch/l4/Makefile) or
any L4Linux sources. This is needed to use the event server, isn't it?

Please see the attached my grub configuration and log.
Jugwan Eom <zugwan at>

More information about the l4-hackers mailing list