Fiasco hello world problem..

raghavendra pai grpai1 at
Thu May 11 07:08:09 CEST 2006


Message: 1
Date: Mon, 8 May 2006 13:48:25 +0200
From: Adam Lackorzynski <adam at>
Subject: Re: Fiasco hello world problem..
To: l4-hackers at
Message-ID: <20060508114825.GI1784 at>
Content-Type: text/plain; charset=iso-8859-1

On Mon May 08, 2006 at 15:04:27 +0530, raghavendra pai wrote:
>    I was trying to run hello world program in Fiasco .
>    I downloaded the hello world from the CVS and did the steps as given in
> the site.
> but I was trying to boot using my pc the hello world program .
> the grub entry in grub.conf file was
> title hello world
>        module /fiasco-boot/main -nokdb
>        module /fiasco-boot/sigma0
>        module /fiasco-boot/roottask
>        module /fiasco-boot/hello
> When i booted it the following was displayed
> Booting "Hello World"
>   module /fiasco/main -nokdb
> Error No:20 Multiboot kernel must be loaded before modules..
> What is the cause of error..

>You forgot 'kernel bootstrap', i.e. the grub entry needs to look like:

>title hello world
>      kernel /fiasco-boot/bootstrap
>      module /fiasco-boot/main -nokdb
>      module /fiasco-boot/sigma0
>      module /fiasco-boot/roottask
>      module /fiasco-boot/hello

I tried to locate the bootstrap file and i got this much entry


which of the one is to be copied into /fiasco-boot folder . I tried using
/root/l4/l4/tool/dice/bootstrap but it tells no file is there
Wht is the problem ? Am i entered the wrong

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the l4-hackers mailing list