Userland (UX) Runtime

Michael J. Emswiler memswiler at
Tue Jun 27 21:26:32 CEST 2006


Just a quick update on my status:

I recompiled fiasco with the GCC 4.1.0.

Unfortunately, it yields the same results for me.

I get up to the same printf as you (Exiting Thread)
However, i do not get a SIGSEGV with any of my fiasco binaries on OpenSuse 
10.1.  According to top() it continues to execute and consume from 65 to 85 % 
of CPU.

This is curious indeed.  I was hoping this would resolve it as I was afraid my 
GCC 3.4.6 installation may have been referencing 4.1 includes or libs or 
something of that nature, but even in the pure 4.1 default environment, it 
does not appear to correctly jump to sigma0's main().

I will keep you posted on my progress, but I am truly at a loss for what to do 
next at this point.

Perhaps you could send me your 4.0 working Fiasco binary, so at least i will 
have a working binary I could use in the interim?

Thanks again for all your help and effort,

On Tuesday 27 June 2006 06:20, Christian Helmuth wrote:
> Hello again,
> I tried your binaries and variouss mixes with compiled binaries on Debian
> and OpenSUSE 10.0 (as this is, what we have here). All combinations
> worked, except those with your fiasco binary.
> We have OpenSUSE 10.0 with GCC 3.4.3 (from
> resp.
> I'd suggest to use a current GCC like 4.0 for building Fiasco.
> Unfortunately, L4 user applications must be built with GCC 3.4 as there
> are some dependencies to Linux 2.4 sources. But we're on the way to fix
> this.
> Let's cross fingers that your problems magically disappear...


More information about the l4-hackers mailing list