Compile Error in L4 Environment

WanKeun Jo jowkju at
Sat Feb 10 08:58:00 CET 2007


I've been using L4 packages and fiasco kernel for ARM platform. At this time, I changed my test 
bed, and made a new environment for L4. 

Using the same cross toolchain as before, I succeed to compile l4 packages and l4linux.
However, when I tried to make a bootstrap image at "l4/build_user/pkg/bootstrap/server/src", 
the following error occured. 

The error doens't occur in the previous machine at all.


Merging image /fiasco to mod00
cp: omitting directory `/fiasco'
Use of uninitialized value in concatenation (.) or string at /home/jowkju/project/Microkernel/Latest/l4/pkg/bootstrap/server/src/ line 198.
mod00.extra.s: Assembler messages:
mod00.extra.s:7: Warning: partial line at end of file ignored
Merging image /home/jowkju/project/Microkernel/Latest/l4/build_user/bin/arm_pxa/l4x0/sigma0 to mod01


  ==> Linking bootstrap.image
LD_PRELOAD=/home/jowkju/project/Microkernel/Latest/l4/tool/gendep/ GENDEP_TARGET=bootstrap.image GENDEP_BINARY=ld  arm-linux-gcc -o bootstrap.image  startup.o exec.o region.o module.o base_critical.o patch.o loader_mbi.o libc_support.o crt0.o init_kip_arm.o mbi_modules.bin mod00.bin mod01.bin mod02.bin mod03.bin mod04.bin mod05.bin mod06.bin mod07.bin mod08.bin mod09.bin mod10.bin mod11.bin mod12.bin mod13.bin mod14.bin mod15.bin -Ttext=0xa1400000  -L/home/jowkju/project/Microkernel/Latest/l4/build_user/lib/arm_pxa/l4x0 -L/home/jowkju/project/Microkernel/Latest/l4/lib/arm_pxa/l4x0 -L/home/jowkju/project/Microkernel/Latest/l4/build_user/lib/arm_pxa -L/home/jowkju/project/Microkernel/Latest/l4/lib/arm_pxa -L/home/jowkju/project/Microkernel/Latest/l4/build_user/lib -L/home/jowkju/project/Microkernel/Latest/l4/lib  -Tbootstrap.ld  -larm_drv-pxa -larm_uart -lcxx_base -lcxx_io -lcxx_io_kdebug -nostdlib -Wl,--nostdlib -ll4util -luc_c /opt/crosstool/gcc-3.4.4-glibc-2.2.5/arm-linux/lib/gcc/arm-linux/3.4.4/libgcc.a -Ttext=0xa1400000 -Wl,--warn-common 
mod00.bin(.module_info+0x0): undefined reference to `_binary_mod00_start'
collect2: ld returned 1 exit status
make[2]: *** [bootstrap.image] Error 1


To fix up the error, I also tried to use the same versions of the tools, which are thought to be related
to the problem - gcc,g++, binutils, make, perl, flex, bison, byacc, automake - as before.
But , the error not fixed..

Could you help me to use "l4" with the new machine??

Thank you...
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the l4-hackers mailing list