Build problems (with automake version)

Michael Roitzsch mroi at os.inf.tu-dresden.de
Wed Mar 7 14:01:31 CET 2007


Hi Ron,

> --- bootstrap	(revision 27879)
> +++ bootstrap	(working copy)
> @@ -56,7 +56,7 @@
>  #
>  if test x"$AUTOMAKE" = x || test x"$ACLOCAL" = x ; then
>    am_ver=""
> -  for ver in "" "-1.9" "-1.8" "-1.7" ; do
> +  for ver in "" "-1.10" "-1.9" "-1.8" "-1.7" ; do
>      am="automake$ver"
>      if ($am --version) < /dev/null > /dev/null 2>&1 ; then
>        if ($am --version | head -n 1 | awk 'NR==1 { if( $(NF) >=  
> '$automake_min_vers') \

I don't think this will fix the problem, because the for-loop will  
already cover automake 1.10, if it is reachable with the plain  
"automake" command. The actual problem, I think, is the awk line to  
compare the versions. awk compares two strings here: 1.10 and 1.9  
(which is $automake_min_vers; this makes me wonder, why 1.7 and 1.8  
are tried at all). Unfortunately, 1.10 is lexically before 1.9, so  
the string compare fails.

Michael

-------------- next part --------------
A non-text attachment was scrubbed...
Name: PGP.sig
Type: application/pgp-signature
Size: 186 bytes
Desc: Signierter Teil der Nachricht
URL: <http://os.inf.tu-dresden.de/pipermail/l4-hackers/attachments/20070307/78a44bea/attachment.sig>


More information about the l4-hackers mailing list