Build problems (with automake version)

Michael Roitzsch mroi at os.inf.tu-dresden.de
Thu Mar 8 10:17:08 CET 2007


Hi Ron,

>>> I do have a plain automake linking to automake-1.9 -> works.
>>> I also have a automake-1.10 binary. To test it I removed the  
>>> empty ""
>>> from the loop and, voila, it worked. Now back to your problem...
>>
>> I guess what happened here is: The for-loop tested 1.10 first. The
>> awk-version-check failed here, so the for loop continued with the  
>> next
>> iteration, testing 1.9. This time the version check worked. So you  
>> were
>> using 1.9 again.
> No. It used automake-1.10. Did you ever try the respective line by  
> hand?

The awk line? Yes, I tried that manually. But wait ...

I just tried again and I guess you found the problem:

This is on erwin:

mroi at erwin:~ > awk --version | head -n 1
GNU Awk 3.1.4
mroi at erwin:~ > awk 'NR==1 { if( $(NF) >= 1.9) print "OK"; else print  
"not OK"; }' <<< 1.10
OK

This is on my Mac OS X:

michael at carpo:~ > awk --version | head -n 1
GNU Awk 3.1.2
michael at carpo:~ > awk 'NR==1 { if( $(NF) >= 1.9) print "OK"; else  
print "not OK"; }' <<< 1.10
not OK

Newer versions of awk seem to compare more elaborately, not with a  
simple string compare. What an awk-ward problem.

Michael

-------------- next part --------------
A non-text attachment was scrubbed...
Name: PGP.sig
Type: application/pgp-signature
Size: 186 bytes
Desc: Signierter Teil der Nachricht
URL: <http://os.inf.tu-dresden.de/pipermail/l4-hackers/attachments/20070308/4dfc0419/attachment.sig>


More information about the l4-hackers mailing list