Build problems (with automake version)

Ronald Aigner ra3 at
Thu Mar 8 16:39:09 CET 2007

Ronald Aigner wrote on 07.03.2007 15:22 this:
>> The actual problem, I think, is the awk line to
>> compare the versions. awk compares two strings here: 1.10 and 1.9 (which
>> is $automake_min_vers; this makes me wonder, why 1.7 and 1.8 are tried
>> at all). Unfortunately, 1.10 is lexically before 1.9, so the string
>> compare fails.
> This is true, I'll have a look into this.
I found some inspiration for a more accurate version check at the curl
project ( Applied is a patch that integrates these
ideas into bootstrap. I removed the check for different versions of
automake (-1.10, -1.9, etc.).  Different versions of the auto* tools can
be set using the environment variables AUTOMAKE, ACLOCAL, AUTOHEADER,

HTH, Ron.
Mit freundlichen Gruessen / with regards
ra3 @
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: dice.bootstrap.diff
URL: <>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 189 bytes
Desc: OpenPGP digital signature
URL: <>

More information about the l4-hackers mailing list