problem compiling l4linux - arm

Tiago Maluta maluta_tiago at
Thu Sep 20 04:58:58 CEST 2007

Hash: SHA1


I'm new to the mailing list but how is the first comment I saw about ARM
processors I decided to post.

My question isn't about a compiling error, but what target boards that
you are using for your tests? Do you using for example Qemu to perform
some of your tests?

Tiago Maluta

Dennis Gessner wrote:
> Hi,
> I have some difficulties, compiling l4linux for arm.
> (I use the toolchain from
> Using the version from SVN (# svn co -N
> tudos), I don't have any problems
> compiling fiasco or the l4env, but if I try to compile l4linux (...
> "repomgr co fiasco dice l4linux-2.6-env" ... and after disabling the
> VGA-Console) - I get the following error-message:
> ---
> l4linux-2.6 # make L4ARCH=arm CROSS_COMPILE=arm-linux-
>   CHK     include/linux/version.h
>   CHK     include/linux/utsrelease.h
>   CALL    scripts/
> <stdin>:91:1: warning: "__IGNORE_sync_file_range" redefined
> In file included from <stdin>:2:
> include/asm-l4/arm-arch/asm/unistd.h:444:1: warning: this is the
> location of the previous definition
> <stdin>:1097:2: warning: #warning syscall fadvise64 not implemented
> <stdin>:1265:2: warning: #warning syscall migrate_pages not implemented
> <stdin>:1321:2: warning: #warning syscall pselect6 not implemented
> <stdin>:1325:2: warning: #warning syscall ppoll not implemented
> <stdin>:1365:2: warning: #warning syscall epoll_pwait not implemented
>   CHK     include/linux/compile.h
>   GEN     .version
>   CHK     include/linux/compile.h
>   UPD     include/linux/compile.h
>   CC      init/version.o
>   LD      init/built-in.o
>   LD      .tmp_vmlinux1
> arch/l4/kernel/arch-arm/built-in.o(.init.text+0x824): In function
> `start_thread':
> /root/tudos/l4linux-2.6/include/asm-l4/arm-arch/asm/current.h:9:
> undefined reference to `l4env_load_initrd'
> make: *** [.tmp_vmlinux1] Error 1
> ---
> How can I solve this error-message?
> By the way, using a l4linux Version from 2007-06-30 works very well, but
> there I have the problem, that the openmoko-kernel-patchset is made for
> linux 2.6.22.x and my 2007-06-30-Version is 2.6.21.x.
> Any help would be very welcome!
> Thanks,
> Dennis
Version: GnuPG v2.0.1 (GNU/Linux)


More information about the l4-hackers mailing list