L4 Demo CD problems

Adam Lackorzynski adam at os.inf.tu-dresden.de
Mon Jan 8 00:05:30 CET 2007


On Mon Jan 08, 2007 at 08:48:46 +1000, Dave Haddon wrote:
> I am using a PC104 stack with a PIII/1Ghz, 256Mb, CD and 6Gig HD... no
> floppy..currently running timesys (6.1) (Linux Kernel for
> i686)
> I eventually got the source for L4 to Compile by leaving out bits that
> were causing compiling errors.. RTC for example.. once I got to that
> point.. my hard drive died and I had to start from scratch.. arrgghh!!!!
> After much stuffing around to find a workable drive for the PC104,
> I figured I'd just download the Demo cd and have a whack at that, and it
> wouldn't work.. I'm starting to get a bit annoyed..
> I originally retrieved the L4linux source from CVS, (l4 and linux-2.6)
> and tried to compile it together from the instructions on the DROPS web
> and had a lot of missing pieces in timesys, (mainly upto-date PERL and
> automake)..
> I haven't tried with QEMU or VMware as I have the PC104 on the same
> monitor and keyboard.. it is too easy to switch between the PC104 and my
> desktop (P4 2.8G, SuSe 9.3, KDE 3.4.0b..with no root permissions...)

You can build everything on your desktop box, you do not need root
permissions for that, even, you should _not_ use root to build anything.
When done you can copy it over, or do network booting, if the hardware
is capable of doing so.

Please post build issues here, I can better help you if I can see what's
going wrong.

Can you connect your testbox and your desktop box with a serial cable so
that we could see the what's going on? Unfortunately when switching to
the graphics mode we do not see much from the debugging logs.

I'd also recommend to use Qemu with the iso image on your desktop,
there's it's probably more fun :)

Adam                 adam at os.inf.tu-dresden.de
  Lackorzynski         http://os.inf.tu-dresden.de/~adam/

More information about the l4-hackers mailing list