Re[2]: and now linking problems

Igor Shmukler shmukler at
Thu Mar 8 05:44:25 CET 2007

> > > > I have another problem. This time it's linking issue. I was compiling
> > > > with gcc 3.3.
> > > >
> > > > Please advise:
> > >
> > > I just tried to reproduce this, with no luck. Linking always worked,
> > > with g++ (4.1) and g++-3.3.
> > >
> > > This is an Ubuntu Feisty, right? Anything special in your setup?
> > 
> > In Edgy, the Ubuntu default compiler (but not the older 3.3 version) has the 
> > stack guard feature enabled by default. We have a fix for Fiasco in SVN, but 
> > Igor said he is still using a CVS checkout, which could be the problem here.

I think because I changed gcc version manually, I probably got have something within the set that's incompatible. Things like that happen, and that's most likely why I bothered the list members. Sorry!

I'll try to check everything more carefully, before disturbing others next time. Hopefully, this will do it. I just hate building a sandbox.

> The CVS version has this particular fix (it's a one-liner). So my
> question remains, Igor. What are software are you using? Are you using
> the latest CVS version?

Makes sense to me. :)

Thanks to everyone again.

More information about the l4-hackers mailing list