Building L4Linux

Adam Lackorzynski adam at
Sun Apr 8 23:13:10 CEST 2007

On Sun Apr 08, 2007 at 22:53:20 +0200, Eduard Benes wrote:
> I run into problem compiling l4linux. I've been able to compile it many 
> times before. But after few weeks while I was not with l4linux stuff, 
> I run into problem when building it. I'm pretty sure it will be some
> "stupid" mistake I've made, but since I need to quickly finish some 
> testing, I would really appreciate any advise...
> Here is configuration I use:
> Debian {sarge, etch}; gcc version: 3.{3,4}, l4linux-2.6-17
> Everything is mainly based on chenggh's kickstart and tarball he provided.
> (

Could you also show the gcc call? (make V=1)
> < l4linux make log start >
> include/asm-l4/i386-arch/asm/alternative.h:7: error: syntax error before "u8"
> include/asm-l4/i386-arch/asm/alternative.h:7: warning: no semicolon at end of struct or union
> include/asm-l4/i386-arch/asm/alternative.h:8: warning: type defaults to `int' in declaration of `replacement'
> include/asm-l4/i386-arch/asm/alternative.h:8: warning: data definition has no type or storage class

I guess gcc doesn't like the u8 because it doesn't know what it means.
Does it help if you add '#include <linux/types.h>' in the beginning of
irq_multi.c? If it doesn't go away now, please also show your .config.

Adam                 adam at

More information about the l4-hackers mailing list