multiple compilations

Davide Fasoli davide.caly at
Mon May 28 09:15:43 CEST 2007

Sorry, link.


I've installed fiasco following the step of the howto I've found here( from this( repository, i've tried following the hints you gave me but still no results.

Adam Lackorzynski <adam at> ha scritto: Hi,

On Fri May 25, 2007 at 13:47:33 +0200, Davide Fasoli wrote:
> when running this command from shell
> make O=/home/fasoz/soa/tudos/l4/prova
> where /home/fasoz/soa/tudos/l4/prova is the installation directory of l4, I had the following text as output:
> ...
> make -C build
> make[2]: Entering directory `/home/fasoz/soa/tudos/kernel/fiasco/build'
> make srcdir=/home/fasoz/soa/tudos/kernel/fiasco/src objbase=/home/fasoz/soa/tudos/kernel/fiasco/build -f /home/fasoz/soa/tudos/kernel/fiasco/src/Makefile.sub1 
> make[3]: Entering directory `/home/fasoz/soa/tudos/kernel/fiasco/build'
> Checking compiler config... unchanged.
> make[3]: Leaving directory `/home/fasoz/soa/tudos/kernel/fiasco/build'
> make srcdir=/home/fasoz/soa/tudos/kernel/fiasco/src objbase=/home/fasoz/soa/tudos/kernel/fiasco/build -f /home/fasoz/soa/tudos/kernel/fiasco/src/Makefile.sub2 all
> make[3]: Entering directory `/home/fasoz/soa/tudos/kernel/fiasco/build'
> -e   ... Making kip.o
> -e   ... Making kip-ia32.o
> -e   ... Making kip-debug.o
> -e   ... Making kip-ia32-debug.o
> -e   ==> Archiving into libabi.a
> -e   ... Ma king boot.o
> gcc: cannot specify -o with -c or -S and multiple compilations
> make[3]: *** [boot.o] Error 1
> make[3]: Leaving directory `/home/fasoz/soa/tudos/kernel/fiasco/build'
> make[2]: *** [all] Error 2
> make[2]: Leaving directory `/home/fasoz/soa/tudos/kernel/fiasco/build'
> make[1]: *** [build] Error 2
> make[1]: Leaving directory `/home/fasoz/soa/tudos/kernel/fiasco'
> make: *** [../kernel/fiasco] Error 2
> I was wondering about what can cause this error, i spent something
> like 15 days on this without coping on... could you please help me? I
> need to install l4 for an exam...

Just plain building the kernel with the default setup works just fine
for me. Which distribution are you using?
And build with more output with "make V=1". Doing this in the
kernel/fiasco/build directory is sufficient.

Adam                 adam at

l4-hackers mailing list
l4-hackers at


L'email della prossima generazione? Puoi averla con la nuova Yahoo! Mail
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the l4-hackers mailing list