Fiasco at ARM - supported hardware

Daniel Vandersee dvandersee at
Tue Jun 19 11:25:28 CEST 2007

Hi Jorge,

I just tried it and it doesn't work for me, too. If I break the program
execution after a while it always stops at uart_write+72:
> 0xb0002e30  <uart_write+64>:  ldr   r3, [r2, #32]
> 0xb0002e34  <uart_write+68>:  tst   r3, #4                     ; 0x4
> 0xb0002e38  <uart_write+72>:  beq   0xb0002e30 <uart_write+64>
> 0xb0002e3c  <uart_write+76>:  ldrb  r3, [r0, r12]

Did you got it running with skyeye? Attached you will find my skyeye
configuration. Maybe you have an idea what goes wrong here? Thanks!


Jorge Torres schrieb:
> Hi Daniel,
> Have you tried PXA borad with skyeye?
> Thanks,
> JOrge
> On 6/18/07, *Daniel Vandersee* < dvandersee at
> <mailto:dvandersee at>> wrote:
>     Hello,
>     how do you test L4 on an ARM platform? Do you have specific hardware
>     for
>     that purpose? You mentioned that you use ARM Integrator boards. As there
>     are several integrator boards available: which one exactly do you use?
>     Do you use other boards as well? I'm asking because I plan to buy an
>     ARM
>     board which is supported out of the box without the need to modify
>     drivers.
>     Do you additionally use software simulators to test L4? If so, which one
>     do you use? I tried Skyeye to simulate an ARM integrator board as well
>     as a SA1100-board but didn't get any output over the serial line. Qemu
>     doesn't work either and terminates with the following error: "qemu:
>     uncaught target signal 11 (Segmentation fault) - exiting".
>     Kind regards,
>     Daniel
>     _______________________________________________
>     l4-hackers mailing list
>     l4-hackers at <mailto:l4-hackers at>

-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: skyeye.conf
URL: <>

More information about the l4-hackers mailing list