Fiasco at ARM - supported hardware

Adam Lackorzynski adam at
Tue Jun 19 13:17:14 CEST 2007


On Mon Jun 18, 2007 at 16:21:10 +0200, Daniel Vandersee wrote:
> how do you test L4 on an ARM platform? Do you have specific hardware for
> that purpose? You mentioned that you use ARM Integrator boards. As there
> are several integrator boards available: which one exactly do you use?
> Do you use other boards as well? I'm asking because I plan to buy an ARM
> board which is supported out of the box without the need to modify drivers.

I'm using Qemu with the integrator targets it offers. I could never test
on a real Integrator board.

> Do you additionally use software simulators to test L4? If so, which one
> do you use? I tried Skyeye to simulate an ARM integrator board as well
> as a SA1100-board but didn't get any output over the serial line. Qemu
> doesn't work either and terminates with the following error: "qemu:
> uncaught target signal 11 (Segmentation fault) - exiting".

Qemu works just fine for me and I cannot remember any crash of Qemu
itself when using it. I've never used skyeye (as Qemu always worked ok
for me).

Adam                 adam at

More information about the l4-hackers mailing list