L4Linux at ARM - Kernel panic (was: Fiasco at ARM - supported hardware)

Adam Lackorzynski adam at os.inf.tu-dresden.de
Sun Jul 1 11:08:39 CEST 2007

On Fri Jun 29, 2007 at 12:27:25 +0200, Daniel Vandersee wrote:
> Hello,
> after I was able to get Fiasco to work with serial output under Qemu
> (Skyeye still doesn't output anything), I'm trying to get L4Linux to
> work with the ARM integrator. Attached you will find a boot log as well
> as my kernel configuration. I tried to remove as much as possible device
> drivers. Do I have to enable/disable some kernel options? I would
> greatly appreciate any help.
> Btw. for some reason I had to link <l4linux>/lib/lib.a to
> <l4linux>/arch/l4/lib/arch-arm/lib.a manually.
> Daniel

You still have to enable CONFIG_BLK_DEV_RAM, at least.
And you don't seem to have included any filesystem (ext2, cramfs) that
is probably needed for the ramdisk to work.

> task "vmlinuz26.arm" "mem=20M root=1:0 load_ramdisk=1 ramdisk_size=4M l4env_rd=rd panicblink=0 lang=de"

console=ttyLv0 l4ser.vkey_enable=1 mem=20M root=1:0 load_ramdisk=1 ramdisk_size=4M l4env_rd=rd init=/bin/sh"

>   priority 0x95
>   all_sects_writable
>   l4env

Adam                 adam at os.inf.tu-dresden.de
  Lackorzynski         http://os.inf.tu-dresden.de/~adam/

More information about the l4-hackers mailing list