about compile environment

sunshine007 kallui.77 at gmail.com
Mon Sep 3 11:34:31 CEST 2007

On Tue Aug 14, 2007 at 20:35:55 -0700, sunshine007 wrote:
> chenggh04 wrote:
> > 
> > On Wednesday 15 August 2007 02:19, sunshine007 wrote:
> >> Thanks adam,
> >>
> >> but now i have problem with booting the L4linux by remote serial
> console.
> >> i follow the pdf kickstart.
> >> but, i still got error like this (after i reboot the machine):
> >> Using IPI shortcut mode
> >> List of all partitions
> >> No file system could not mount root, tried :
> >> kernel panic - not syncing
> >> VFS : unable to mount root fs on unknown block (0,0)
> > 	These information shows that your Fiasco has no problem and it could
> drag
> > the 
> > booting of L4Linux. But the L4Linux can't find or mount the root file
> > system.
> > 	If VFS can't mount root fs with unknown blocks. First you should check
> > your 
> > l4linux configuration with the filesystem type as ext2, ext3, etc.
> > Basically 
> > you should compile the ext2 or ext3 into the linux kernel not compile as 
> > modules.
> > 
> cheng, 
> sorry , i could not understand what u meant ? so, how to check myl4linux
> configuration ? using cfdisk ?
> i checked, my partition /sda3 , FS type is Linux ext2.
> so, actually this can be solved or not. or i need to reformat my hardisk ?
> sorrry i can't get u. :,(

No, you do not need to reformat your hard disk, your hard disk is fine.
Besides that you need to have the filesystem used on your root partition
compiled into Linux you also need to have the driver for the disk
controller compiled in. Please make sure this is the case.

honestly speaking , actually i do not how to solved this kernel panic
I have google a lot of url with the same issue but i still could not solve
the kernel panic.
some that recommend to alter the L4linux configuration like this one : 

so, i  my kernel can't load the modules, do i need the mkinitrd ?
It to run L4linux by serial console we need to create the initrd ? or use
the ramdisk ?


i paste again full code of my menu.lst :
# Linux bootable partition config begins
  title Slackware on (/dev/sda3)
  root (hd0,2)
  kernel /boot/vmlinuz root=/dev/sda3 ro vga=normal
 title L4Linux-2.6/Fiasco+dope
 root (hd0,2)
 kernel /boot/L4linux/bootstrap
  modaddr 0x02000000
  module /boot/L4linux/fiasco -nowait -nokdb -serial_esc -comspeed 115200
 -comport 1
  module /boot/L4linux/sigma0
  module /boot/L4linux/roottask task modname "bmodfs" attached 4 modules
  module /boot/L4linux/events
  module /boot/L4linux/names --events
  module /boot/L4linux/log --events
  module /boot/L4linux/dm_phys  --isa=0x00800000 -v --events
  module /boot/L4linux/simple_ts -t 300 --events
  module /boot/L4linux/rtc --events
  module /boot/L4linux/l4io --noirq --events module
  module /boot/L4linux/loader --fprov=BMODFS linux26.cfg
  module /boot/L4linux/bmodfs
  module /boot/L4linux/vmlinuz
  module /boot/L4linux/linux26.cfg
  module /boot/L4linux/libloader.s.so
  module /boot/L4linux/libld-l4.s.so 
#end line

View this message in context: http://www.nabble.com/about-compile-environment-tf4247269.html#a12458816
Sent from the L4 mailing list archive at Nabble.com.

More information about the l4-hackers mailing list