L4Linux-2.6

kazilus kazilus amadkamal at yahoo.com
Fri Jan 11 08:03:58 CET 2008


thanks bjoern,

the problem fixed now,

but still failed to load L4Linux

here is the error

No filesystem could mount root, tried:
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

any idea?

----- Original Message ----
From: Bjoern Doebel <doebel at os.inf.tu-dresden.de>
To: kazilus kazilus <amadkamal at yahoo.com>
Cc: l4-hackers at os.inf.tu-dresden.de
Sent: Friday, January 11, 2008 2:26:06 PM
Subject: Re: L4Linux-2.6


kazilus kazilus schrieb:
> and this is inside my linux26.cfg
> 
> modpath "(hda0,2)/boot/L4Linux"
> task "vmlinuz" "earlyprintk=yes console=ttyS0,115200 init=1 mem=256M 
> root=/dev/hda3" all_sects_writable allow_vga
> 
> ----- Original Message ----
> From: kazilus kazilus <amadkamal at yahoo.com>
> To: l4-hackers at os.inf.tu-dresden.de
> Sent: Friday, January 11, 2008 8:54:07 AM
> Subject: L4Linux-2.6
> 
> hi all
> 
> i got problem when booting L4Linux
> 
> here i got stuck with:
> 
> ======> L4Linux 2.6 starting... <======
> The running kernel does not have the segments
> feature enable!

"The running kernel" in this case refers to the Fiasco kernel. Go to 
your Fiasco build dir, do make config and select the "Handle and 
preserve segments" option. Then rebuild Fiasco.

Regards,
Bjoern






      ____________________________________________________________________________________
Be a better friend, newshound, and 
know-it-all with Yahoo! Mobile.  Try it now.  http://mobile.yahoo.com/;_ylt=Ahu06i62sR8HDtDypao8Wcj9tAcJ 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://os.inf.tu-dresden.de/pipermail/l4-hackers/attachments/20080110/5f791eb4/attachment.html>


More information about the l4-hackers mailing list