L4Linux-2.6

kazilus kazilus amadkamal at yahoo.com
Fri Jan 11 10:37:06 CET 2008


this is my menu.lst

title L4Linux-26/Fiasco+Serial+Console
root (hd0,2)
kernel /boot/L4Linux/bootstrap
modaddr 0x06000000
module /boot/L4Linux/main -nowait -nokdb -serial_esc
module /boot/L4Linux/sigma0
module /boot/L4Linux/roottask task modname "bmodfs" attached 4 modules
module /boot/L4Linux/events
module /boot/L4Linux/names --events
module /boot/L4Linux/log --events
module /boot/L4Linux/dm_phys --isa=0x00800000 -v --events
module /boot/L4Linux/simple_ts -t 300 --events
#module /boot/L4Linux/rtcc --events
module /boot/L4Linux/l4io --noirq --events module
#module /boot/L4Linux/l4exec --events
module /boot/L4Linux/loader --fprov=BMODFS linux26.cfg
module /boot/L4Linux/bmodfs
module /boot/L4Linux/vmlinuz
module /boot/L4Linux/linux26.cfg
module /boot/L4Linux/libloader.s.so
module /boot/L4Linux/libld-l4.s.so

and this is my linux26.cfg

modpath "(hda0,2)/boot/L4Linux"
task "vmlinuz" "earlyprintk=yes init=1 mem=256M root=/dev/hda3" 
all_sects_writable 
allow_vga

and what does the "init=1" means

----- Original Message ----
From: kazilus kazilus <amadkamal at yahoo.com>
To: Bjoern Doebel <doebel at os.inf.tu-dresden.de>
Cc: l4-hackers at os.inf.tu-dresden.de
Sent: Friday, January 11, 2008 3:03:58 PM
Subject: Re: L4Linux-2.6


thanks bjoern,

the problem fixed now,

but still failed to load L4Linux

here is the error

No filesystem could mount root, tried:
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

any idea?

----- Original Message ----
From: Bjoern Doebel <doebel at os.inf.tu-dresden.de>
To: kazilus kazilus <amadkamal at yahoo.com>
Cc: l4-hackers at os.inf.tu-dresden.de
Sent: Friday, January 11, 2008 2:26:06 PM
Subject: Re: L4Linux-2.6


kazilus kazilus schrieb:
> and this is inside my linux26.cfg
> 
> modpath "(hda0,2)/boot/L4Linux"
> task "vmlinuz" "earlyprintk=yes console=ttyS0,115200 init=1 mem=256M 
> root=/dev/hda3" all_sects_writable allow_vga
> 
> ----- Original Message ----
> From: kazilus kazilus <amadkamal at yahoo.com>
> To: l4-hackers at os.inf.tu-dresden.de
> Sent: Friday, January 11, 2008 8:54:07 AM
> Subject: L4Linux-2.6
> 
> hi all
> 
> i got problem when booting L4Linux
> 
> here i got stuck with:
> 
> ======> L4Linux 2.6 starting... <======
> The running kernel does not have the segments
> feature enable!

"The running kernel" in this case refers to the
 Fiasco kernel. Go to 
your Fiasco build dir, do make config and select the "Handle and 
preserve segments" option. Then rebuild Fiasco.

Regards,
Bjoern









      Never miss a thing.   Make Yahoo your homepage.







      ____________________________________________________________________________________
Be a better friend, newshound, and 
know-it-all with Yahoo! Mobile.  Try it now.  http://mobile.yahoo.com/;_ylt=Ahu06i62sR8HDtDypao8Wcj9tAcJ 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://os.inf.tu-dresden.de/pipermail/l4-hackers/attachments/20080111/f615010c/attachment.html>


More information about the l4-hackers mailing list