Error compile L4

ahmad kamal amadkamal at
Fri Jan 18 04:52:28 CET 2008

finally fiasco got compile with gcc 4.1.2

here is what i did

remove binutils package and re-install it again

get fiasco latest source code and compile it

so i guess something wrong with default binutils package in slackware even it comes with correct version

thanks you very much all

----- Original Message ----
From: Adam Lackorzynski <adam at>
To: l4-hackers at
Sent: Friday, January 18, 2008 2:04:52 AM
Subject: Re: Error compile L4

On Wed Jan 16, 2008 at 16:16:17 -0800, ahmad kamal wrote:
> > Ah yes, slack. I'm told that slack12 has gcc-4.1.2 and
> > binutils How does it come you have gcc-3.4.6? And
> > version of binutils?
> yes, slack by default is gcc-4.1.2, but for fiasco i soflink gcc with
> gcc-3.4.6 to avoid a lot of promblem when compiling, and by default
> slack use binutils Am i using correct version of
> binutils?

binutils should be ok but also try with gcc-4.1. gcc-4.1 should
generally work. Otherwise I would need more inspection of this.

Adam                 adam at

l4-hackers mailing list
l4-hackers at

Never miss a thing.  Make Yahoo your home page.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the l4-hackers mailing list