error while compiling the l4.

Adam Lackorzynski adam at
Tue Apr 8 22:43:03 CEST 2008

On Tue Apr 08, 2008 at 20:40:07 +0200, wrote:
> > >  I think It can work on AMD64,could you help me?thank you very much!
> >
> > Note that only a subset works on amd64 compared to ia32. I thus
> > recommend using ia32.
> 	I think if we have a pure 64-bit machine but we indeed to run fiasco with 
> full features, as Adam suggested to use ia32 , qemu is good choice. 
> 	we could use qemu to emulate a pure 32-bit environment for the Fiasco/32-bit. 
> Right?

Any amd64 machine can run normal ia32 code, not just 64bit code. But
using qemu for trying things out is probably a good idea anyway.

Adam                 adam at

More information about the l4-hackers mailing list