Unable to mount /dev/root

Adam Lackorzynski adam at os.inf.tu-dresden.de
Mon May 5 21:05:34 CEST 2008

On Sat May 03, 2008 at 18:45:47 +0400, Igor V. Ruzanov wrote:
> No, i don't see such logs. Exactly output of rest of the boot looks like:
> [...some messages about loading of usb modules, hotplug configuring...]
> Loading scsi_mod.ko module
> SCSI subsystem initialized
> Loading sd_mod.ko module
> Driver 'sd' needs updating - please use bus_type methods
> Loading libata.ko module
> Loading ahci.ko module
> Waiting for driver initialization
> Creating root device
> Mounting root filesystem
> mount: could not find filesystem '/dev/root'
> [...and still several messages about impossibility of mounting /sys and 
> /proc filesystems before terminating of init and panic state...]
> I'm trying to research problem towards of PCI probing through mmconfig.. 
> In my kernel config is CONFIG_PCI_GOMMCONFIG=y used. GODIRECT resulted 
> __unknown_pf(). It might be due to some mmconfig failures during l4linux 
> boot and incorrect work of ahci driver as result.
> Unfortunately i cannot provide you full log of l4linux boot stages because 
> i haven't any methods (physical COM-port with attached machine as a 
> console with X11 and some console application with text buffering). Does 
> theoretically (at least) mmconfig can make problems within l4env?

It's not unlikely but I would need to look myself. Can you tell me what
the problem with GODIRECT is? That's the mode that is usually supposed
to work.

Adam                 adam at os.inf.tu-dresden.de
  Lackorzynski         http://os.inf.tu-dresden.de/~adam/

More information about the l4-hackers mailing list