Installing problem with gcc-4.2.3

盛淑蕙 saya.sheng at
Wed May 14 05:09:06 CEST 2008

Grub-0.97 with grub-0.97-os.5.diff can be successfully compiled by
gcc-4.1.3 and it can work well.


2008/5/14 fei li <tezuka158 at>:
> Hi, all
> I have installed l4 on ubuntu8.04 these days,  the compiling process is ok,
> but  when I finished compiling the packages, i reboot and find that the grub
> doesn't support. Then i patch the grub-0.97-os.6.diff, there are errors when
> i use the gcc-4.2.3, then i turn to gcc-4.1.3, and everything is ok, but
> when i finished the grub installing, i find i can't enter the ubuntu 8.04,
> it says error 27, don't know the command, something like that. Then i
> uninstall the patched grub and install the grub from the source, it's ok,
> but i can't enter the l4, I guess you can have a test, if it's true, I guess
> we need a os.7 patch for gcc-4.2.3 or something else. That's all!
> _______________________________________________
>  l4-hackers mailing list
>  l4-hackers at

More information about the l4-hackers mailing list