Problems with l4linux

Adam Lackorzynski adam at
Wed Oct 15 23:31:58 CEST 2008

On Tue Oct 14, 2008 at 22:04:49 +1300, Valery V. Sedletski wrote:
> I have Mandriva 2008.0 distribution.
> I compiled l4linux and got some problems with it. Maybe anyone knows
> what's wrong with the configuration?
> First, the problem is with X11 (X.Org), when I'm launching X11 by
> typing startx, there is an error 
> tal server error:
> xf86EnableIOPorts: failed to set IOPL for I/O (Invalid argument)
> I compiled in the L4con/DOpE stubs but X11 don't work. On ordinary
> Linux Kernel it works well. I tried to use a fbdev driver in X.Org.

fbdev is a driver that will work. The problem is that X wants to have IO
privileges which L4Linux does not have. This is actually feature rather
than a bug. Why should X need IO privileges for just running the fbdev
driver? Anyway, add 'allow_cli' in the loader config script to the
L4Linux load line, and 'task modname "loader" allow_cli' to the roottask
cmdline and it should give L4Linux/X the rights it likes to have.

> Also, each time I access /dev/null, the message is displayed that
> access is denied.

How do you try to access it? /dev/null should look like this:
0 crw-rw-rw- 1 root root 1, 3 Jan  1 00:00 /dev/null

> Third, I got PCMCIA GPRS modem to power up and register in a GSM
> network (power Led is on and Network available Led is flashing). This
> modem appears to an OS like ordinary PCMCIA comm port, but minicom
> does not react to AT commands, though, PCMCIA stack detected the card,
> but did not enabled ttyS0 and ttyS1 ports on the card. It seems I
> loaded all PCMCIA stack modules and hotplug support. Except for
> serial_cs module which warns that "no high memory space available!".
> When I did configuring the linux Kernel, the build system did not give
> me a possibility to specify high memory up to 4 Gb. What should I do
> with it?

Is the modem really using ttyS0? ttyS0 is used by Fiasco for the serial
console and thus not available to L4Linux (or any other app). You can
specify '-noserial' on the Fiasco command line to disable the usage of
> Fourth, I thied a wifi MiniPCI card Intel PRO/Wireless 2200 to get
> working in l4linux. I tried to load all wifi modules like in ordinary
> Linux kernel on the same machine, but when I trying to make the
> network interface up, it says that device does not exists. When I
> check dmesg output, there is a message that a firmware could not be
> loaded. I unchecked the checkbox "Prevent the firmware from being
> built" and "Do not enable drivers which require firmware loading" and
> it seems that firmware must be built. The firmware is in /lib/firmware
> and is called ipw2200-bss.fw. What should I do to get firmware loaded?

The FW_LOADER config option is not enabled. I guess this needs to be so.

> The question is, does hotplug work in l4linux and does work PCMCIA and
> wifi support and should I try it and what options I could miss?

hotplug is supposed to work. Neven tried PCMCIA myself but I don't see
why it should not work.

> Also I noticed that CD writing by cdrdao and cdrecord does not work,
> the console is either hangs until reboot, or the number of call trace
> messages are displayed.

Never tried to burn a CD like this.

> And the last, I tried to build l4linux under l4linux itself. The build
> is generally working, except for when doing "make modules_install"
> depmod crashes. Should I report these errors or they are known
> problems?

Is it depmod or something different? depmod should work as Debian
systems running it on every boot-up. Please report, I'll try to fix as I

Adam                 adam at

More information about the l4-hackers mailing list